We are continuing to experience a technical issue with Mastercard Payment Transaction. Our technical resources continue to work to resolve the issue as a matter of priority.
Posted Oct 12, 2025 - 02:52 UTC
Identified
We are continuing to experience a technical issue with Mastercard Payment Transaction. Our technical resources continue to work to resolve the issue as a matter of priority.
Posted Oct 12, 2025 - 02:50 UTC
Investigating
We are currently experiencing a technical issue with Mastercard Payment Transaction. Technical resources are working to identify and resolve the issue as a matter of priority.
Posted Oct 12, 2025 - 02:30 UTC
This incident affected: Payouts (Mastercard Payment Transaction (PT)).