We are continuing to investigate potential issues with PayPal

Incident Report for WPG

Monitoring

We are continuing to experience a technical issue with PayPal. Our technical resources continue to work to resolve the issue as a matter of priority.
Posted Oct 26, 2025 - 02:25 UTC

Investigating

We are currently experiencing a technical issue with PayPal. Technical resources are working to identify and resolve the issue as a matter of priority.
Posted Oct 26, 2025 - 02:24 UTC
This incident affects: Alternative Payment Methods (APMs) (PAYPAL).