We have resolved the technical issue with Merchant Admin Interface. The system is now operating as expected. We apologize for any inconvenience this may have caused you or your customers.
Posted Mar 25, 2026 - 17:00 UTC
Investigating
We are investigating potential issues with Merchant Admin Interface
Posted Mar 25, 2026 - 16:17 UTC
This incident affected: Portals (Merchant Admin Interface/Business Manager).