We are investigating potential issues with Wallets - Apple Pay

Incident Report for WPG

Resolved

We are investigating potential issues with Wallets - Apple Pay
Posted Jun 24, 2025 - 02:47 UTC

Investigating

We are investigating potential issues with Wallets - Apple Pay
Posted Jun 24, 2025 - 01:17 UTC
This incident affected: Wallets (Apple Pay).