We are continuing to investigate potential issues with Ideal

Incident Report for WPG

Resolved

This incident has been resolved.
Posted Oct 12, 2025 - 09:36 UTC

Update

We are continuing to experience a technical issue with Ideal. Our technical resources continue to work to resolve the issue as a matter of priority.
Posted Oct 12, 2025 - 02:54 UTC

Identified

We are continuing to experience a technical issue with Ideal. Our technical resources continue to work to resolve the issue as a matter of priority.
Posted Oct 12, 2025 - 02:52 UTC

Investigating

We are currently experiencing a technical issue with Ideal. Technical resources are working to identify and resolve the issue as a matter of priority.
Posted Oct 12, 2025 - 02:51 UTC
This incident affected: Alternative Payment Methods (APMs) (IDEAL).