We are investigating potential issues with Wallets - Google Pay

Incident Report for WPG

Resolved

We are investigating potential issues with Wallets - Google Pay
Posted May 21, 2026 - 18:15 UTC

Investigating

We are investigating potential issues with Wallets - Google Pay
Posted May 21, 2026 - 18:04 UTC
This incident affected: Wallets (Google Pay).