We are investigating potential issues with China Union Pay
Incident Report for WPG
Resolved
This incident has been resolved.
Posted Dec 18, 2024 - 14:14 UTC
Investigating
We are currently experiencing a technical issue with China Union Pay. Technical resources are working to identify and resolve the issue as a matter of priority.
Posted Dec 18, 2024 - 12:46 UTC
This incident affected: Alternative Payment Methods (APMs) (China Union Pay).